Search Service

GALAXY NOTE 2 READ BEFORE ORDERING: 

If your Note 2 has a firmware version/baseband that is not supported, you may be required to downgrade the firmware 

in order to unlock. No refunds are given if you have the unsupported firmware version/baseband. 

This only applies to Note 2 

 

Supported: I317M VLALJ2 4.1.1, 4.1.1 (all Note 2) 

Not Supported: i317M VLBMA3, 4.1.2 (all Note 2) 


$USD

No Records Found